AppFabric Installation Fails with 1603 Error

KB 1017: AppFabric Installation Fails with 1603 Error




Problem Statement

During installation of AppFabric, installation fails with 1603 error.

Symptoms


Installation of AppFabric fails, does not work log shows 1603 error. 

Cause


There are two possible reasons for this. One is PSModulePath Value is not correct or AS_Observers /AS_Administrators group(s) are available in Local Groups.

Steps to Reproduce


Change the value of PSModulePath or just add AS_Observers and AS_Administrators groups to local groups of the machine before running the installation.

Resolution


To resolve this issue two things we need to verify:

  1. PSModulePath values are pointing to correct locations.
  2. Above mentioned groups should not be present in Local Users and Groups.

PSModulePath

  1. Open Control Panel > System and Security > System.
  2. Click on Advance system settings from the left pane


  1. Click on Environment Variables.



  1. Scroll bottom window and select PSModulePath.


  1. Edit the values to look like below:

C:\Windows\System32\WindowsPowerShell\v1.0\Modules 

C:\Windows\System32\WindowsPowerShell\v1.0\

Or 

%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\Modules

%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\


Must not have and character at the end                                                                                                                             

Local Groups

  1. Open Computer Management.


  1. Expand Local Users and Groups from the left pane.


  1. Select Groups and make sure there is not group named AS_Observers and AS_Administrators in there. If you see, simply delete.

Once the above two things are verified, rerun the setup again.

Additional Information





                                                 Author:  Fawad Laiq

                                                Date published: May 20th, 2020